]> err.no Git - sope/blobdiff - maintenance/mod_ngobjweb_suse92.spec
added dependency checking, added strip=yes support
[sope] / maintenance / mod_ngobjweb_suse92.spec
index f26adc0202f6d4704e1a3e0e257a5866a8ede3af..be8a72a87aa0bf9207ff9cb4dba30ae8b6d41e22 100644 (file)
@@ -23,7 +23,7 @@ OpenGroupware.org application server.
 
 %prep
 rm -fr ${RPM_BUILD_ROOT}
-%setup -n sope-mod_ngobjweb
+%setup -q -n sope-mod_ngobjweb
 
 # ****************************** build ********************************
 %build
@@ -62,7 +62,7 @@ if [ $1 = 0 ]; then
 fi
 
 # ****************************** trigger ******************************
-%triggerin -- ogo-webui-app, ogoall
+%triggerin -- ogo-webui-app
 if [ $2 = 1 ]; then
 echo "# configuration needed to access the OGo webui
 #
@@ -85,7 +85,7 @@ Alias /ArticleImages %{_var}/lib/opengroupware.org/news
 " >%{apache_conf_dir}/ogo-webui.conf
 fi
 
-%triggerin -- ogo-xmlrpcd, ogoall
+%triggerin -- ogo-xmlrpcd
 if [ $2 = 1 ]; then
 echo "# configuration needed to access the OGo XMLRPCd via http
 #
@@ -99,7 +99,7 @@ echo "# configuration needed to access the OGo XMLRPCd via http
 " >%{apache_conf_dir}/ogo-xmlrpcd.conf
 fi
 
-%triggerin -- ogo-zidestore, ogoall
+%triggerin -- ogo-zidestore
 if [ $2 = 1 ]; then
 echo "# configuration needed to access the OGo ZideStore via http
 #
@@ -113,21 +113,77 @@ echo "# configuration needed to access the OGo ZideStore via http
 " >%{apache_conf_dir}/ogo-zidestore.conf
 fi
 
-%triggerun -- ogo-webui-app, ogoall
+%triggerin -- ogoall
+if [ $2 = 1 ]; then
+echo "# configuration needed to access the OGo webui
+#
+# explicitly allow access
+<Directory %{prefix}/share/opengroupware.org-1.0a/www> 
+  Order allow,deny 
+  Allow from all 
+</Directory>
+# required aliases
+Alias /OpenGroupware10a.woa/WebServerResources/ %{prefix}/share/opengroupware.org-1.0a/www/
+Alias /ArticleImages %{_var}/lib/opengroupware.org/news
+#
+# hook up
+<IfModule ngobjweb_module.c>
+  <LocationMatch "^/OpenGroupware*">
+    SetAppPort 20000
+    SetHandler ngobjweb-adaptor
+  </LocationMatch>
+</IfModule>
+" >%{apache_conf_dir}/ogo-webui.conf
+echo "# configuration needed to access the OGo XMLRPCd via http
+#
+# hook up
+<IfModule ngobjweb_module.c>
+  <LocationMatch "^/RPC2*">
+    SetAppPort 22000
+    SetHandler ngobjweb-adaptor
+  </LocationMatch>
+</IfModule>
+" >%{apache_conf_dir}/ogo-xmlrpcd.conf
+echo "# configuration needed to access the OGo ZideStore via http
+#
+# hook up
+<IfModule ngobjweb_module.c>
+  <LocationMatch "^/zidestore/*">
+    SetAppPort 21000
+    SetHandler ngobjweb-adaptor
+  </LocationMatch>
+</IfModule>
+" >%{apache_conf_dir}/ogo-zidestore.conf
+fi
+
+%triggerun -- ogoall
+if [ $2 = 0 ]; then
+  if [ -f %{apache_conf_dir}/ogo-webui.conf ]; then
+    rm -f %{apache_conf_dir}/ogo-webui.conf
+  fi
+  if [ -f %{apache_conf_dir}/ogo-xmlrpcd.conf ]; then
+    rm -f %{apache_conf_dir}/ogo-xmlrpcd.conf
+  fi
+  if [ -f %{apache_conf_dir}/ogo-zidestore.conf ]; then
+    rm -f %{apache_conf_dir}/ogo-zidestore.conf
+  fi
+fi
+
+%triggerun -- ogo-webui-app
 if [ $2 = 0 ]; then
   if [ -f %{apache_conf_dir}/ogo-webui.conf ]; then
     rm -f %{apache_conf_dir}/ogo-webui.conf
   fi
 fi
 
-%triggerun -- ogo-xmlrpcd, ogoall
+%triggerun -- ogo-xmlrpcd
 if [ $2 = 0 ]; then
   if [ -f %{apache_conf_dir}/ogo-xmlrpcd.conf ]; then
     rm -f %{apache_conf_dir}/ogo-xmlrpcd.conf
   fi
 fi
 
-%triggerun -- ogo-zidestore, ogoall
+%triggerun -- ogo-zidestore
 if [ $2 = 0 ]; then
   if [ -f %{apache_conf_dir}/ogo-zidestore.conf ]; then
     rm -f %{apache_conf_dir}/ogo-zidestore.conf