4 Summary: Scalable OpenGroupware.org (Inverse edition)
6 Version: %{sogo_version}.%{sogo_release}
7 Release: gnustep.%{dist_suffix}
8 Vendor: http://www.inverse.ca/
9 Packager: Wolfgang Sourdeau <wsourdeau@inverse.ca>
11 URL: http://www.inverse.ca/contributions/sogo.html
12 Group: Productivity/Groupware
13 Source: %{sogo_source}
14 Prefix: %{sogo_prefix}
16 Requires: gnustep-base sope%{sope_major_version}%{sope_minor_version}-core httpd mod_ngobjweb sope%{sope_major_version}%{sope_minor_version}-cards
17 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}
18 BuildPreReq: gcc-objc gnustep-base gnustep-make sope%{sope_major_version}%{sope_minor_version}-appserver-devel sope%{sope_major_version}%{sope_minor_version}-core-devel sope%{sope_major_version}%{sope_minor_version}-ldap-devel sope%{sope_major_version}%{sope_minor_version}-mime-devel sope%{sope_major_version}%{sope_minor_version}-xml-devel sope%{sope_major_version}%{sope_minor_version}-gdl1-devel sope%{sope_major_version}%{sope_minor_version}-cards-devel
21 SOGo is a groupware server built around OpenGroupware.org (OGo) and
22 the SOPE application server. It focuses on scalability.
24 The Inverse edition of this project has many feature enhancements:
25 - CalDAV and GroupDAV compliance
26 - full handling of vCard as well as vCalendar/iCalendar formats
27 - support for folder sharing and ACLs
29 The Web interface has been rewritten in an AJAX fashion to provided a faster
30 UI for the users, consistency in look and feel with the Mozilla applications,
31 and to reduce the load of the transactions on the server.
33 %package -n sogo-devel
34 Summary: Development headers and libraries for SOGo
35 Group: Development/Libraries/Objective C
38 %description -n sogo-devel
39 Development headers and libraries for SOGo. Needed to create modules.
41 %package -n sope%{sope_major_version}%{sope_minor_version}-gdl1-contentstore
42 Summary: Storage backend for folder abstraction.
43 Group: Development/Libraries/Objective C
44 Requires: sope%{sope_major_version}%{sope_minor_version}-gdl1
47 %description -n sope%{sope_major_version}%{sope_minor_version}-gdl1-contentstore
48 The storage backend implements the "low level" folder abstraction, which is
49 basically an arbitary "BLOB" containing some document.
51 SOPE is a framework for developing web applications and services. The
52 name "SOPE" (SKYRiX Object Publishing Environment) is inspired by ZOPE.
54 %package -n sope%{sope_major_version}%{sope_minor_version}-gdl1-contentstore-devel
55 Summary: Development files for the GNUstep database libraries
56 Group: Development/Libraries/Objective C
57 Requires: sope%{sope_major_version}%{sope_minor_version}-gdl1
60 %description -n sope%{sope_major_version}%{sope_minor_version}-gdl1-contentstore-devel
61 This package contains the header files for SOPE's GDLContentStore library.
63 SOPE is a framework for developing web applications and services. The
64 name "SOPE" (SKYRiX Object Publishing Environment) is inspired by ZOPE.
67 %package -n sope%{sope_major_version}%{sope_minor_version}-gdl1-tools
68 Summary: Tools (gcs_cat/gcs_gensql/gcs_ls/gcs_mkdir/gcs_recreatequick)
69 Group: Development/Libraries/Objective C
70 Requires: sope%{sope_major_version}%{sope_minor_version}-gdl1
73 %description -n sope%{sope_major_version}%{sope_minor_version}-gdl1-tools
74 Various tools around the GDLContentStore.
76 SOPE is a framework for developing web applications and services. The
77 name "SOPE" (SKYRiX Object Publishing Environment) is inspired by ZOPE.
79 ########################################
81 rm -fr ${RPM_BUILD_ROOT}
84 # ****************************** build ********************************
86 . /usr/GNUstep/System/Library/Makefiles/GNUstep.sh
94 # ****************************** install ******************************
96 make INSTALL_ROOT_DIR=${RPM_BUILD_ROOT} \
97 GNUSTEP_INSTALLATION_DIR=${RPM_BUILD_ROOT}%{prefix} \
99 cp -a UI/WebServerResources UI/Templates ${RPM_BUILD_ROOT}%{prefix}/Library/SOGo-%{sogo_version}
100 mkdir -p ${RPM_BUILD_ROOT}/etc/init.d
101 mkdir -p ${RPM_BUILD_ROOT}/etc/httpd/conf.d
102 mkdir -p ${RPM_BUILD_ROOT}/usr/sbin
103 mkdir -p ${RPM_BUILD_ROOT}/var/run/sogo
104 mkdir -p ${RPM_BUILD_ROOT}/var/log/sogo
105 cp Apache/SOGo.conf ${RPM_BUILD_ROOT}/etc/httpd/conf.d/
106 cp Scripts/sogo-init.d-rhel4 ${RPM_BUILD_ROOT}/etc/init.d/sogod
107 cp Scripts/sogod-redhat ${RPM_BUILD_ROOT}/usr/sbin/sogod
108 rm -rf ${RPM_BUILD_ROOT}%{prefix}/Tools/test_quick_extract
109 rm -rf ${RPM_BUILD_ROOT}%{prefix}/Library/Headers/NGCards
110 rm -rf ${RPM_BUILD_ROOT}%{prefix}/Library/Libraries/libNGCards.*
111 rm -rf ${RPM_BUILD_ROOT}%{prefix}/Library/SaxDrivers-%{sope_major_version}.%{sope_minor_version}
112 rm -rf ${RPM_BUILD_ROOT}%{prefix}/Library/SaxMappings
114 # ****************************** clean ********************************
116 rm -fr ${RPM_BUILD_ROOT}
118 # ****************************** files ********************************
120 %defattr(-,root,root,-)
123 /etc/httpd/conf.d/SOGo.conf
127 %{prefix}/Tools/sogod-0.9
128 %{prefix}/Library/Libraries/libSOGo.so.*
129 %{prefix}/Library/Libraries/libSOGoUI.so.*
130 %{prefix}/Library/Libraries/libOGoContentStore.so*
131 %{prefix}/Library/SOGo-%{sogo_version}/*.SOGo
132 %{prefix}/Library/SOGo-%{sogo_version}/Templates
133 %{prefix}/Library/SOGo-%{sogo_version}/WebServerResources
134 %{prefix}/Library/OCSTypeModels/appointment.ocs
135 %{prefix}/Library/OCSTypeModels/contact.ocs
136 %{prefix}/Library/OCSTypeModels/appointment-oracle.ocs
137 %{prefix}/Library/OCSTypeModels/contact-oracle.ocs
138 %{prefix}/Library/WOxElemBuilders-%{sope_version}/SOGoElements.wox
140 %doc ChangeLog README NEWS Scripts/sql-update-20070724.sh Scripts/sql-update-20070822.sh
143 %{prefix}/Library/Headers/SOGo
144 %{prefix}/Library/Headers/SOGoUI
145 %{prefix}/Library/Libraries/libSOGo.so
146 %{prefix}/Library/Libraries/libSOGoUI.so
148 %files -n sope%{sope_major_version}%{sope_minor_version}-gdl1-contentstore
149 %defattr(-,root,root,-)
150 %{prefix}/Library/Libraries/libGDLContentStore*.so.%{sope_version}*
152 %files -n sope%{sope_major_version}%{sope_minor_version}-gdl1-contentstore-devel
153 %{prefix}/Library/Headers/GDLContentStore
154 %{prefix}/Library/Libraries/libGDLContentStore*.so
156 %files -n sope%{sope_major_version}%{sope_minor_version}-gdl1-tools
157 %defattr(-,root,root,-)
158 %{prefix}/Tools/gcs_cat
159 %{prefix}/Tools/gcs_gensql
160 %{prefix}/Tools/gcs_ls
161 %{prefix}/Tools/gcs_mkdir
162 %{prefix}/Tools/gcs_recreatequick
164 # **************************** pkgscripts *****************************
166 if ! id sogo >& /dev/null; then /usr/sbin/adduser sogo; fi
167 /bin/chown sogo /var/run/sogo
168 /bin/chown sogo /var/log/sogo
173 /usr/sbin/userdel sogo
174 /usr/sbin/groupdel sogo
175 /bin/rm -rf /var/run/sogo
178 # ********************************* changelog *************************
180 * Tue Oct 4 2007 Francis Lachapelle <flachapelle@inverse.ca>
181 - added package sope-gdl1-contentstore
183 * Wed Jul 18 2007 Wolfgang Sourdeau <wsourdeau@inverse.ca>