]> err.no Git - sope/blob - maintenance/mod_ngobjweb_suse92.spec
put OGo.conf into the apache conf.d dir where possible;
[sope] / maintenance / mod_ngobjweb_suse92.spec
1 Summary:        mod_ngobjweb apache module
2 Name:           mod_ngobjweb
3 Version:        %{mod_ngobjweb_version}
4 Release:        %{mod_ngobjweb_release}.%{mod_ngobjweb_buildcount}%{dist_suffix}
5 Vendor:         OpenGroupware.org
6 Packager:       Frank Reppin <frank@opengroupware.org>  
7 License:        LGPL
8 URL:            http://sope.opengroupware.org/
9 Group:          Development/Libraries
10 AutoReqProv:    off
11 Requires:       apache2 ogo-environment
12 Source:         %{mod_ngobjweb_source}
13 Prefix:         %{mod_ngobjweb_prefix}
14 BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
15
16 %description
17 apache2 mod_ngobjweb adaptor.
18
19 %prep
20 rm -fr ${RPM_BUILD_ROOT}
21 %setup -n sope-mod_ngobjweb
22
23 # ****************************** build ********************************
24 %build
25 export PATH=$PATH:/usr/sbin
26 make %{mod_ngobjweb_makeflags} APXS="/usr/sbin/apxs2" APXS_INCLUDE_DIRS="-I/usr/include/apache2"
27
28 # ****************************** install ******************************
29 %install
30 export PATH=$PATH:/usr/sbin
31 mkdir -p ${RPM_BUILD_ROOT}%{_usr}/lib/apache2
32 cp mod_ngobjweb.so ${RPM_BUILD_ROOT}%{_usr}/lib/apache2/mod_ngobjweb.so
33
34 mkdir -p ${RPM_BUILD_ROOT}%{_sysconfdir}/apache2/conf.d/
35 echo "#this file contains the apache/httpd configuration for OpenGroupware.org
36 #it should be included from within your default httpd.conf ala:
37 #\`include OGo.conf\`
38 #(or copy it into the dir where additonal configs end up - usually conf.d/)
39 #
40 #SUSEs httpd.conf denies access to everywhere (except /srv/www) per default
41 <Directory %{prefix}/share/opengroupware.org-1.0a/www> 
42   Order allow,deny 
43   Allow from all 
44 </Directory>
45 #
46 LoadModule ngobjweb_module %{_usr}/lib/apache2/mod_ngobjweb.so
47 #
48 Alias /OpenGroupware10a.woa/WebServerResources/ %{prefix}/share/opengroupware.org-1.0a/www/
49 Alias /ArticleImages %{_var}/lib/opengroupware.org/news
50 #
51 <LocationMatch "^/OpenGroupware*">
52   SetAppPort 20000
53   SetHandler ngobjweb-adaptor
54 </LocationMatch>
55 #
56 <LocationMatch "^/zidestore/*">
57   SetHandler ngobjweb-adaptor
58   SetAppPort 21000
59 </LocationMatch>
60 #
61 <LocationMatch "^/RPC2*">
62   SetHandler ngobjweb-adaptor
63   SetAppPort 22000
64 </LocationMatch>
65 " > ${RPM_BUILD_ROOT}%{_sysconfdir}/apache2/conf.d/OGo.conf
66
67 # ****************************** post *********************************
68 %post
69
70 # ****************************** clean ********************************
71 %clean
72 rm -fr ${RPM_BUILD_ROOT}
73
74 # ****************************** files ********************************
75 %files
76 %defattr(-,root,root,-)
77 %{_usr}/lib/apache2/mod_ngobjweb.so
78 %config %{_sysconfdir}/apache2/conf.d/OGo.conf
79
80 # ********************************* changelog *************************
81 %changelog
82 * Thu Dec 23 2004 Frank Reppin <frank@opengroupware.org>
83 - requires apache2 -obviously-
84 - mod_ngobjweb.so lives in /usr/lib/apache2/modules now
85 - OGo.conf lives in /etc/apache2/conf.d now...
86 - which fixes -> http://bugzilla.opengroupware.org/bugzilla/show_bug.cgi?id=1020
87 * Wed Dec 21 2004 Frank Reppin <frank@opengroupware.org>
88 - dealt with http://bugzilla.opengroupware.org/bugzilla/show_bug.cgi?id=1084
89 * Wed Sep 09 2004 Frank Reppin <frank@opengroupware.org>
90 - initial build