]> err.no Git - sope/blob - maintenance/mod_ngobjweb_suse91.spec
retab everything; mod_ngobjweb* with better description.
[sope] / maintenance / mod_ngobjweb_suse91.spec
1 Summary:        mod_ngobjweb apache module
2 Name:           mod_ngobjweb
3 Version:        %{mod_ngobjweb_version}
4 Release:        %{mod_ngobjweb_release}.%{mod_ngobjweb_buildcount}%{dist_suffix}
5 Vendor:         OpenGroupware.org
6 Packager:       Frank Reppin <frank@opengroupware.org>  
7 License:        LGPL
8 URL:            http://sope.opengroupware.org/
9 Group:          Development/Libraries
10 AutoReqProv:    off
11 Requires:       apache2 ogo-environment
12 Source:         %{mod_ngobjweb_source}
13 Prefix:         %{mod_ngobjweb_prefix}
14 BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
15
16 %description
17 Enables apache to handle HTTP requests for the
18 OpenGroupware.org application server
19
20 %prep
21 rm -fr ${RPM_BUILD_ROOT}
22 %setup -n sope-mod_ngobjweb
23
24 # ****************************** build ********************************
25 %build
26 export PATH=$PATH:/usr/sbin
27 make %{mod_ngobjweb_makeflags} APXS="/usr/sbin/apxs2" APXS_INCLUDE_DIRS="-I/usr/include/apache2"
28
29 # ****************************** install ******************************
30 %install
31 export PATH=$PATH:/usr/sbin
32 mkdir -p ${RPM_BUILD_ROOT}%{_usr}/lib/apache2
33 cp mod_ngobjweb.so ${RPM_BUILD_ROOT}%{_usr}/lib/apache2/mod_ngobjweb.so
34
35 mkdir -p ${RPM_BUILD_ROOT}%{_sysconfdir}/apache2/conf.d/
36 echo "#this file contains the apache/httpd configuration for OpenGroupware.org
37 #it should be included from within your default httpd.conf ala:
38 #\`include OGo.conf\`
39 #(or copy it into the dir where additonal configs end up - usually conf.d/)
40 #
41 #SUSEs httpd.conf denies access to everywhere (except /srv/www) per default
42 <Directory %{prefix}/share/opengroupware.org-1.0a/www> 
43   Order allow,deny 
44   Allow from all 
45 </Directory>
46 #
47 LoadModule ngobjweb_module %{_usr}/lib/apache2/mod_ngobjweb.so
48 #
49 Alias /OpenGroupware10a.woa/WebServerResources/ %{prefix}/share/opengroupware.org-1.0a/www/
50 Alias /ArticleImages %{_var}/lib/opengroupware.org/news
51 #
52 <LocationMatch "^/OpenGroupware*">
53   SetAppPort 20000
54   SetHandler ngobjweb-adaptor
55 </LocationMatch>
56 #
57 <LocationMatch "^/zidestore/*">
58   SetHandler ngobjweb-adaptor
59   SetAppPort 21000
60 </LocationMatch>
61 #
62 <LocationMatch "^/RPC2*">
63   SetHandler ngobjweb-adaptor
64   SetAppPort 22000
65 </LocationMatch>
66 " > ${RPM_BUILD_ROOT}%{_sysconfdir}/apache2/conf.d/OGo.conf
67
68 # ****************************** post *********************************
69 %post
70
71 # ****************************** clean ********************************
72 %clean
73 rm -fr ${RPM_BUILD_ROOT}
74
75 # ****************************** files ********************************
76 %files
77 %defattr(-,root,root,-)
78 %{_usr}/lib/apache2/mod_ngobjweb.so
79 %config %{_sysconfdir}/apache2/conf.d/OGo.conf
80
81 # ********************************* changelog *************************
82 %changelog
83 * Thu Dec 23 2004 Frank Reppin <frank@opengroupware.org>
84 - requires apache2 -obviously-
85 - mod_ngobjweb.so lives in /usr/lib/apache2/modules now
86 - OGo.conf lives in /etc/apache2/conf.d now...
87 - which fixes -> http://bugzilla.opengroupware.org/bugzilla/show_bug.cgi?id=1020
88 * Wed Dec 21 2004 Frank Reppin <frank@opengroupware.org>
89 - dealt with http://bugzilla.opengroupware.org/bugzilla/show_bug.cgi?id=1084
90 * Wed Sep 09 2004 Frank Reppin <frank@opengroupware.org>
91 - initial build