]> err.no Git - sope/blob - maintenance/mod_ngobjweb_conectiva10.spec
updated Xcode projects (dyld versions, added new files)
[sope] / maintenance / mod_ngobjweb_conectiva10.spec
1 Summary:      mod_ngobjweb apache module
2 Name:         mod_ngobjweb
3 Version:      %{mod_ngobjweb_version}
4 Release:      %{mod_ngobjweb_release}.%{mod_ngobjweb_buildcount}%{dist_suffix}
5 Vendor:       OpenGroupware.org
6 Packager:     Frank Reppin <frank@opengroupware.org>  
7 License:      LGPL
8 URL:          http://sope.opengroupware.org/
9 Group:        Development/Libraries
10 AutoReqProv:  off
11 Requires:     apache ogo-environment
12 Source:       %{mod_ngobjweb_source}
13 Prefix:       %{mod_ngobjweb_prefix}
14 BuildRoot:    %{_tmppath}/%{name}-%{version}-%{release}-root
15
16 %description
17 Enables apache to handle HTTP requests for the
18 OpenGroupware.org application server
19
20 %prep
21 rm -fr ${RPM_BUILD_ROOT}
22 %setup -n sope-mod_ngobjweb
23
24 # ****************************** build ********************************
25 %build
26 export PATH=$PATH:/usr/sbin
27 make %{mod_ngobjweb_makeflags} APXS_INCLUDE_DIRS="-I/usr/include/apache"
28
29 # ****************************** install ******************************
30 %install
31 export PATH=$PATH:/usr/sbin
32 mkdir -p ${RPM_BUILD_ROOT}/usr/lib/apache/modules
33 cp mod_ngobjweb.so ${RPM_BUILD_ROOT}/usr/lib/apache/modules/
34
35 mkdir -p ${RPM_BUILD_ROOT}%{_sysconfdir}/apache/conf/conf.d/
36 echo "#this file contains the apache/httpd configuration for OpenGroupware.org
37 #it should be included from within your default httpd.conf ala:
38 #\`include OGo.conf\`
39 #(or copy it into the dir where additonal configs end up - usually conf.d/)
40 #
41 LoadModule ngobjweb_module %{_usr}/lib/apache/modules/mod_ngobjweb.so
42 #
43 Alias /OpenGroupware10a.woa/WebServerResources/ %{prefix}/share/opengroupware.org-1.0a/www/
44 Alias /ArticleImages %{_var}/lib/opengroupware.org/news
45 #
46 <LocationMatch "^/OpenGroupware*">
47   SetAppPort 20000
48   SetHandler ngobjweb-adaptor
49 </LocationMatch>
50 #
51 <LocationMatch "^/zidestore/*">
52   SetHandler ngobjweb-adaptor
53   SetAppPort 21000
54 </LocationMatch>
55 #
56 <LocationMatch "^/RPC2*">
57   SetHandler ngobjweb-adaptor
58   SetAppPort 22000
59 </LocationMatch>
60 " > ${RPM_BUILD_ROOT}%{_sysconfdir}/apache/conf/conf.d/OGo.conf
61
62 # ****************************** post *********************************
63
64 # ****************************** clean ********************************
65 %clean
66 rm -fr ${RPM_BUILD_ROOT}
67
68 # ****************************** files ********************************
69 %files
70 %defattr(-,root,root,-)
71 %{_usr}/lib/apache/modules/mod_ngobjweb.so
72 %config %{_sysconfdir}/apache/conf/conf.d/OGo.conf
73
74 # ********************************* changelog *************************
75 %changelog
76 * Wed Jan 12 2005 Frank Reppin <frank@opengroupware.org>
77 - initial build