]> err.no Git - sope/blob - libFoundation/libfoundation.spec
fixed some NGMail framework build issue
[sope] / libFoundation / libfoundation.spec
1 Summary:      Implementation of the OpenStep specification.
2 Name:         libfoundation%{libf_major_version}%{libf_minor_version}
3 Version:      %{libf_version}
4 Release:      %{libf_release}.%{libf_buildcount}%{dist_suffix}
5 Vendor:       OpenGroupware.org
6 Packager:     Frank Reppin <frank@opengroupware.org>  
7 License:      libFoundation license
8 URL:          http://www.opengroupware.org
9 Group:        Development/Libraries
10 AutoReqProv:  off
11 Source:       %{libf_source}
12 Prefix:       %{libf_prefix}
13 Requires:     libobjc-lf2
14 Conflicts:    libfoundation
15 BuildRoot:    %{_tmppath}/%{name}-%{version}-%{release}-root
16
17 %description
18 libFoundation is a library that provides an almost complete
19 implementation of the OpenStep specification plus many other extensions
20 that can be found in the Apple's MacOS X Foundation library.
21
22 %package devel
23 Summary:      Development files for libFoundation.
24 Group:        Development/Libraries
25 Requires:     ogo-gnustep_make libfoundation%{libf_major_version}%{libf_minor_version}
26 AutoReqProv:  off
27 Conflicts:    libfoundation-devel
28
29 %description devel
30 This package contains the development files of libFoundation.
31
32 libFoundation is a library that provides an almost complete
33 implementation of the OpenStep specification plus many other extensions
34 that can be found in the Apple's MacOS X Foundation library.
35
36 %prep
37 rm -fr ${RPM_BUILD_ROOT}
38 %setup -q -n libfoundation
39
40 # ****************************** build ********************************
41 %build
42 source %{prefix}/OGo-GNUstep/Library/Makefiles/GNUstep.sh
43 export CFLAGS=-Wno-import
44 ./configure
45 make %{libf_makeflags} all
46
47 # ****************************** install ******************************
48 %install
49 source %{prefix}/OGo-GNUstep/Library/Makefiles/GNUstep.sh
50 mkdir -p ${RPM_BUILD_ROOT}%{prefix}/lib
51 mkdir -p ${RPM_BUILD_ROOT}%{prefix}/OGo-GNUstep/Library/Makefiles/Additional
52
53 make %{libf_makeflags} INSTALL_ROOT_DIR=${RPM_BUILD_ROOT} \
54                        GNUSTEP_INSTALLATION_DIR=${RPM_BUILD_ROOT}%{prefix} \
55                        FHS_INSTALL_ROOT=${RPM_BUILD_ROOT}%{prefix} \
56                        install
57
58 rm -f ${RPM_BUILD_ROOT}%{prefix}/Library/Headers/libFoundation/extensions/exceptions/FoundationException.h
59 rm -f ${RPM_BUILD_ROOT}%{prefix}/Library/Headers/libFoundation/extensions/exceptions/GeneralExceptions.h
60 rm -f ${RPM_BUILD_ROOT}%{prefix}/Library/Headers/libFoundation/extensions/exceptions/NSCoderExceptions.h
61
62
63 # ****************************** post *********************************
64 %post
65 if [ $1 = 1 ]; then
66   if [ -d %{_sysconfdir}/ld.so.conf.d ]; then
67     echo "%{prefix}/lib" > %{_sysconfdir}/ld.so.conf.d/libfoundation.conf
68   elif [ ! "`grep '%{prefix}/lib' %{_sysconfdir}/ld.so.conf`" ]; then
69     echo "%{prefix}/lib" >> %{_sysconfdir}/ld.so.conf
70   fi
71   /sbin/ldconfig
72 fi
73
74 # ****************************** postun *********************************
75 %postun
76 if [ $1 = 0 ]; then
77   if [ -e %{_sysconfdir}/ld.so.conf.d/libfoundation.conf ]; then
78     rm -f %{_sysconfdir}/ld.so.conf.d/libfoundation.conf
79   fi
80   /sbin/ldconfig
81 fi
82
83 # ****************************** clean ********************************
84 %clean
85 rm -fr ${RPM_BUILD_ROOT}
86
87 # ****************************** files ********************************
88 %files
89 %defattr(-,root,root,-)
90 %{prefix}/bin/Defaults
91 %{prefix}/lib/libFoundation*.so.%{libf_version}
92 %{prefix}/lib/libFoundation*.so.%{libf_major_version}.%{libf_minor_version}
93 %{prefix}/share/libFoundation/CharacterSets
94 %{prefix}/share/libFoundation/Defaults
95 %{prefix}/share/libFoundation/TimeZoneInfo
96
97 %files devel
98 %defattr(-,root,root,-)
99 %{prefix}/OGo-GNUstep/Library/Makefiles/Additional/libFoundation.make
100 %{prefix}/include/lfmemory.h
101 %{prefix}/include/real_exception_file.h
102 %{prefix}/include/Foundation
103 %{prefix}/include/extensions
104 %{prefix}/lib/libFoundation*.so
105
106 # ********************************* changelog *************************
107 %changelog
108 * Wed Mar 16 2005 Frank Reppin <frank@opengroupware.org>
109 - conflicts: libfoundation (the former name of the package)
110 * Tue Jan 18 2005 Frank Reppin <frank@opengroupware.org>
111 - dealt with http://bugzilla.opengroupware.org/bugzilla/show_bug.cgi?id=1182
112 * Wed Sep 09 2004 Frank Reppin <frank@opengroupware.org>
113 - initial build